Overview
Users may be unable to log in to the web portal when they forget their password or username or when their security role does not have permissions for the group assigned to the user.
Diagnosis
- If the user encounters the error "Invalid Login", it means that either username or password was entered incorrectly.
- If the user is getting the error "You have been logged out because you are not authorized to access the requested page", the security role associated with their user account does not have permissions to the group assigned to the same user. A company admin can follow the steps below to confirm if this is the root cause:
- Log in to the Field Force Manager web portal using your credentials and company ID.
- Navigate to Administration > Users.
- Locate the affected user and check their group and role:
- Navigate to Administration > Roles.
- Click on the role assigned to the user (from step 3) and click Edit Role.
- Check if the role has permissions for the group to which the user is assigned.
In this example, Mr Smith is assigned to the Mobile Worker group, but the role provides access only to the Alert Administration permissions.
Solution
- If the user forgot their password or username, they can reset the password themselves or a company administrator can change the password manually and check the username under Administration > Users:
- If the user security role does not have permissions to the group, there are three possible solutions:
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- Reassign the user to another group that is accessible for the selected Security Role.
- Modify the user's security role to enable access to the group to which the user is assigned.
- Assign another security role to the user - the role must have access to the group to which the user is assigned.
- Reassign the user to another group that is accessible for the selected Security Role.
Testing
The user should be able to log in to the Field Force Manager web portal and access the features enabled for the assigned security role.