Overview
Field workers are unable to activate the mobile app due to the following message:
Server communication error. Please try again, or contact your administrator.
Diagnosis
There are two possible reasons:
- Internet connection is not working on your mobile device.
Open any web page in a browser on your device to check if the page is loading. If it is not loading, check if mobile data is enabled on your device. - There may be an error in the application cache files that prevents it from communicating with the server.
Solution
- If the mobile data is enabled and pages are not loading on your device, you or your manager need to contact your carrier to check why mobile data is not working on your phone.
- If the internet connection on your mobile device is working fine, perform the following actions:
- Uninstall the mobile app from the device.
- Reboot your mobile device.
- Install the Field Force Manager mobile app from scratch.
- Uninstall the mobile app from the device.
Testing
You should be able to activate the mobile app without issues.