Overview
Workers cannot view Timesheet Summary in the mobile app and encounter the following message (while they have logged work time during previous weeks):
No Timesheet actions for the last 40 days.
Prerequisites
You need to have an account with Company Administrator, Super User role, or a custom role with rights to edit users.
Diagnosis
This issue happens when the time zone on the worker's mobile device differs from the time zone configured for their account when creating a user. To confirm if this is the case:
- Ask the worker to check which time zone is configured on their mobile device:
- From the web portal, navigate to Administration > Users.
- Click on the required worker account and select Edit User.
- Check the Time Zone selected for the worker:
Solution
After following steps 2-6 from Diagnosis, select the Time Zone that matches the worker's time zone configured on the mobile device and click Save & Close.
Testing
The worker should do the following:
- Tap on the Sync button to make sure that the updated user settings are downloaded from the server.
- Tap on the Timesheets icon.
- Tap on the Summary tab.
The timesheets for the previous 40 days are displayed: