Overview:
A mobile worker while activating a device gets an error "this phone number is already in use by another device" after she/he enters the phone number.
Diagnosis:
This error can be caused for two reasons:
- The device was assigned to the current worker but was in use by another worker before you.
- The Application was uninstalled from the current device or a previous device without doing a "Clear Activation".
Due to either of the reasons, the Phone Number is being considered as activated on some Device by the Web Application.
Pre-requisites:
You need to have an account with Company Administrator, Super User role, or a custom role with access to deactivate Devices.
Solution:
Follow the steps below to resolve the problem:
- Deactivate the specific Device and ensure to check the "prompt the worker to enter PIN".
- Retrieve the PIN Number of the Device and provide it to the Worker
- Ask the Mobile worker to Activate the Mobile Application with the Phone Number and the PIN Number Provided.
Testing:
- The Mobile Worker should be able to successfully activate the Mobile Application
- The activated device is highlighted and the Activated Date field contains the date-time of the activation.